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基本概念

This manual copyright 2005-2013 Perforce Software. 

All rights reserved. 

Perforce software and documentation is available from http://www.perforce.com. You may download and use Perforce programs, 

but you may not sell or redistribute them. You may download, print, copy, edit, and redistribute the documentation, but you may not 

sell it, or sell any documentation derived from it. You may not modify or attempt to reverse engineer the programs. 

This product is subject to U.S. export control laws and regulations including, but not limited to, the U.S. Export Administration 

Regulations, the International Traffic in Arms Regulation requirements, and all applicable end-use, end-user and destination 

restrictions. Licensee shall not permit, directly or indirectly, use of any Perforce technology in or by any U.S. embargoed country or 

otherwise in violation of any U.S. export control laws and regulations. 

Perforce programs and documents are available from our Web site as is. No warranty or support is provided. 

Warranties and support, along with higher capacity servers, are sold by Perforce Software. 

Perforce Software assumes no responsibility or liability for any errors or inaccuracies that may appear in this book. 

By downloading and using our programs and documents you agree to these terms. 

Perforce and Inter-File Branching are trademarks of Perforce Software. Perforce software includes software developed by the 

University of California, Berkeley and its contributors. This product includes software developed by the OpenSSL Project for use in 

the OpenSSL Toolkit (http://www.openssl.org/). 

All other brands or product names are trademarks or registered trademarks of their respective companies or organizations. 

本手册的中文版本由上海龙智数码科技股份有限公司(http://www.shdsd.com)翻译 

本手册版权归Perforce公司（ Perforce Software）所有 

保留一切权利. 

Perforce软件和文档可以从http://www.perforce.com上获得。你可以下载和使用Perforce程序，但你不能转售或

发布。你可以下载、打印、复制、编辑和分发这些文档，但你不得销售它们，或销售任何采自它们的文档。不得修改或试

图反向工程这些程序。 

本产品受制于美国出口管制法律和条例，包括但不限于：美国出口行政法规、国际贸易中的军火出口管制条例的要求

和所有适用的最终用途、最终用户及目的地的限制。被许可者不得直接或间接地在任何美国禁运国家或违反任何美国出口

管制法律和条例使用任何Perforce技术。 

对于从我们网站上下载的Perforce程序和文档，不提供质保或支持。 

高性能服务器下的质保和支持是由Perforce公司（Perforce Software）销售的。 

Perforce Software对这本书中可能出现的任何错误或疏漏不承担任何责任或义务。 

下载和使用我们的程序和文档，视同同意上述这些条款。 

Perforce和Inter-File Branching 是Perforce Software的商标。 Perforce software包括由California大学，

Berkeley  大 学 和 他 们 的 捐 赠 者 所 开 发 的 软 件 。 本 产 品 包 括 由  OpenSSL  项 目 开 发 的 用 于  OpenSSL 

Toolkit(http://www.openssl.org/)的软件。 

所有其他商标或产品名称是他们各自公司或组织的商标或注册商标。
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P4V入门

P4V（Perforce可视化客户端）是Perforce跨平台图形化用户界面。你可以在Windows,Mac,

UNIX 和 Linux 各种平台上使用 P4V，且各种平台都有相同的界面。这本介绍性指南主要介绍

Perforce的基本知识和P4V布局及主要特征。如果想了解更多关于P4V的内容，请参照P4V在线

帮助。如果想学习更多关于Perforce的话，请参照我们网站的用户文档。

使用Perforce来管理文件时，你通常会使用P4V之类的应用程序连接到Perforce版本控制

服务器。通过 P4V 签入签出文件，并执行其它各种版本控制任务。以下章节将教你如何利用 P4V

来实现基本的版本控制并提供一些P4V的强大功能和快捷方式。

基本概念

如下图所示，通过P4V来连接你的计算机和Perforce服务器，以完成文件在Perforce服务

器的depot和你的工作区之间传输，

这些Perforce术语的定义如下：

• 工作区：对Perforce所管理的文件进行工作时，所用到的本地工作站的文件夹或目录。

•Perforce应用程序：P4V(或别的Perforce应用程序),   在你的工作站上运行，从Perforce

版本控制服务发出请求并把这些请求的结果（文件，状态信息等）发给你。

• 服务：Perforce 版本控制服务响应来自Perforce 应用程序的请求，维护 depot 文件，跟

踪工作区的状态。

• Depot: 由 Perforce 服务管理的文件仓库。它包含所有已提交文件的各个版本信息。

Perforce服务可以同时管理多个depot，但该指南的示例只列举了一个depot。

连接到Perforce

为访问Perforce服务器上的文件，你首先需要连接Perforce服务器。第一次启动P4V时，

连接设置向导（Mac：连接设置助手）会引导你完成整个配置连接过程，其中需要你指定服务器、

用户 ID 和工作区。可以通过后面的方法启动向导/助手，选择[ Connection] >  [  Set  Up
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连接到  Perforce

Connection...]。

另一种方法，你也可以在如下的这个对话框中配置连接：

1. 启动P4V，P4V显示以下的连接对话框：

2. 指定以下各项(你的Perforce管理员会提供这些信息)。

• Server：托管共享版本控制服务的机器的名称。你还必须指定 TCP/IP 和端口。如果你用

SSL连接到Perforce，则用  ssl:主机名:端口.

• User：你的Perforce 用户名。

• Password：如果需要的话，输入Perforce用户密码.

• Workspace：你的工作区名。

点击[Browse…]以显示既存用户和工作区（在点击[Browse…]之前，必须先指定服务器和端

口）。

如果你指定的服务器设置不正确，P4V显示以下的信息。

Connect to server failed; check $P4PORT.

TCP connect to bigserver failed.

bigserver: host unknown.

3. 点[OK]连接。P4V显示如下的主画面。
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主画面导航

主画面导航

下图展示该面板和主画面的重要功能。把鼠标移到对应的按钮或屏幕单元上可以查看其功能。

因为P4V会显示该按钮或屏幕但隐患的描述性提示信息。

工具栏按钮

切换面板。
左面板显示

depot 和工

作区中的文

件和文件夹。
右面板显示

所选对象的

详细。

日志面板列出服务器命令；

Dashboard显示状态和任务快捷方式。
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设置你的工作区

Perforce系统管理员可以为你做这些，但建议你掌握一些配置工作区的重要方面，特别是：

（1）配置工作区根目录和（2）配置工作区视图。

为了定义工作区，选择[Connection]> [New Workspace....]在对话框中输入工作区名。为

了编辑当前工作区式样，选择[Connection]> [Edit Current Workspace...]

P4V在右侧面板的下半部显示式样详细，例如：

Root：指定Perforce在你工

作站上存储 depot 文件副本

的位置。指定一个有意义的

名字，并保证它不是你的计

算机的根目录！

WorkspaceMapping：使你能

筛选你要访问的depot文件。

把该视图设置成只看你需要

看的。

为了图形化显示和设置工作区视图，点击[Basic]标签。右击所要的文件和文件夹，把它们

包含进工作区映射中或从工作区映射中排除，如下图所示。
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管理你的文件

一般的，你利用Perforce管理文件时，执行下列步骤的任务。

1. 从depot中读取文件。

2. 签出你需要编辑的文件。

3. 编辑文件。

4. 签入你的变更。

以下章节提供这些及其他共通文件管理任务的详细说明。

从depot读取文件

从depot拷贝文件到工作区：

1. 在左侧面板，点击[Depot]标签。

2. 光标移到想要读取的文件夹或文件。

3. 右击文件或文件夹。想要取得最新版本的话，选择[Get  Latest Revision]。 想要取得

某个旧版本的话，选择[Get Revision...]并指定你想要的版本号。

在日志面板上，P4V显示如下信息：

p4 sync //depot/Misc/manuals/...#head

//depot/Misc/manuals/recommended_configuration.doc added c:\p4clients\bruno-149

2\Misc\manuals\recommended_configuration.doc

//depot/Misc/manuals/triggers.doc added c:\p4clients\bruno-1492\Misc\manuals\tr

iggers.doc

//depot/Misc/manuals/vendor_branches.doc added c:\p4clients\bruno-1492\Misc\manu

als\vendor_branches.doc

Sync copied 3 files to workspace (including 3 that were added)

Sync removed no files from workspace

Sync completed with no warnings or errors.

在左侧面板，注意文件显示绿点：   表示它们已存在于工作区中。在你编辑文件之前，你

必须先把它签出。

从depot签出文件

在工作区中签出文件：

1. 在左侧面板的[depot]标签中，把光标移到想要请签出的文件。

2. 右击该文件并选择[Check Out]。

在日志面板上，P4V显示如下信息：

p4 edit //bruno-1492/Misc/manuals/recommended_configuration.doc

//depot/Misc/manuals/recommended_configuration.doc#1 - opened for edit

Opened 1 files for edit

11Perforce2013.1 P4V入门



 

管理你的文件

在左侧面板，注意文件显示红色打钩标志，表示它已被签出：

注意：当你签出文件时，Perforce把它加到一个changelist中，该changelist是一系列关

联文件的列表。你可以用changelists来归类相互关联的文件，例如：所有包含实现产品新功能

所需的变更的文件。要查看changelist，选择[View] > [Pending  Changelists]或点击工具栏。

选择你已经可以编辑文件了。

在你的工作区中编辑文件

要编辑签出了的文件，双击该文件（或右击该文件后选择[Open With]，再选择应用程序）。

P4V启动相应的编辑应用程序。编辑该文件后保存。

要选择一个打开文件的应用程序，点击[File]>[Open With]>[Choose Application]。 你可

以在[Preferences]对话框的[File Editors]子页中配置编辑器。

添加新文件到depot

要添加文件到 depot，你需要进行以下两个操作。首先，你把该文件标记为以添加为目的，

把该文件放在一个changelist中，然后，你提交该changelist,把该文件拷贝到depot中。

添加文件到depot ：

1. 在左侧面板，点击[Workspace]标签。

2. 把光标移到想要请添加的文件。如果该文件不在depot的话，它的图标就没有标记   。

如果你在Workspace子标签页中没有看到该本地文件，选择[Search]>[FilterWorkspace]>[Show

Local Workspace Files]。

3. 右击该文件并选择[Mark for Add]. 该文件图标显示一个红色加号   ，表示它以追加目

的打开。

4. 提交包含以追加目的打开的文件的 changelist 。右击该文件后选择[Submit].... 显示

工作中Changelist表单，列出该changelist中的文件。（参照“把变更签入depot”)。

比较文件内容以查看变更

为了查看你做了哪些变更，你可以把你所编辑的文件与你签出的版本比较。为了做比较，在

左侧面板中右击签出了的文件并选择[Diff Against Have Revision]。 P4V启动比较工具，显示

这两个文件的差分。例如：
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通过恢复废弃变更

如果你决定废弃变更的话：

1.在左侧面板中右击该文件并选择[Revert]. P4V显示警告对话框。

2. 点击 [OK]. 在日志面板上，P4V显示如下信息：:

p4 revert //depot/Misc/manuals/recommended_configuration.doc

revert complete. 1 file affected.

把变更签入depot

为了把变更了的文件签入depot，执行以下步骤：

1. 显示作业中  changelist: 点击工具栏中的 图标。P4V  显示如下图所示的作业中

changelist一览。要显示该changelist中的文件的话，展开它。
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2. 双击你文件所在的changelist。P4V显示如下图所示的详细信息。

3. 输入注释说明你所做的变更，然后点击[Submit]. 日志面板显示类似下面的信息，提示

你的changelist已被提交。

Change 813 submitted.

submit complete. 1 file affected.
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显示文件的版本历史

要查看文件或文件夹所做的变更，右击该文件或文件夹后选择[File    History]或[Folder

History].在右侧面板上显示所选文件或文件夹的历史。例如，下图显示一个文件夹的历史，列

出了所有影响该文件夹内文件的已提交了的changelist。
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图形化报表工具

P4V包含几种有用的图形化报表工具：

•  Revision Graph：以图形的形式显示所选文件的演变过程，包括该文件的所有分支操作。

•  Time-lapse View：显示所选文本文件的内容从一个版本到另一个版本是如何变化的。你可

以很容易地浏览版本范围以定位你所感兴趣的段落以查看该段落是何时创建又是如何变化的。

• 文件夹比较工具：使你可以查看文件夹的内容是如何变化的。

以下章节提供有关这些工具的更详细的信息。

用 Revision Graph的方式查看文件版本演变

为了显示一个文件的版本演变过程，在左侧面板中右击该文件并选择[RevisionGraph].P4V

弹出工具，显示如下的版本演变图。

该版本演变图显示该文件是何时创建的又是如何被分支的，并使你可以查看提交到depot的

每个版本的细节，利用导航图可以在版本演变图上浏览。如果想了解更多关于版本演变图所显示

信息的话，你可以参照P4V在线帮助。

利用 Time-lapse View浏览文件版本

为了浏览一个文本文件所发生的变化，在左侧面板中右击该文件并选择[Time-lapse View]。

P4V 启动工具，显示如下画面。
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滑块：移动以浏览各

版本

变更详情：显示版本中所

增删改了的文本。

利用[Time-lapse View], 你可以移动滑块浏览所有的版本，留意何时做了变更、谁做了变更。

重申一下，如果想了解更多信息的话，你可以参照P4V在线帮助。

用文件夹比较工具显示文件夹历史

文件夹比较工具使你可以查看文件夹的内容是如何变化的：哪些文件被增删改了。要查看一

个文件夹所发生的变化：

1.右击左侧面板的[Depot]或[Workspace]子标签页中的文件夹，选择[Folder History]. 在

右侧面板中，P4V列出跟该文件夹有关的changelist，例如：

2. 要查看文件夹的两个版本之间所发生的变更，可以把一个版本拖放到另一个版本上。

P4V 显示如下图所示的变化。该例子显示在所选的版本之间，一个文件被编辑并被签入。文

件用颜色高亮显示以表示增删改。展开文件夹并定位到所感兴趣的变更。要移到下一个或前一个

变更，点击左箭头或右箭头。
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点击这些箭头以浏览变更。
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查看 Streams

Perforcestreams是“智能化的分支”，是一个管理类似于代码行之类相关文件的集成化方

法。如果你的团队使用 streams 的话，你将在[Depot]面板中看到[streams depots]。[streams

depots]的图示为   。要在depot中显示streams的话，

1. 点击[Streams]工具栏按钮： ,即显示Streams子标签页。

2. 要显示stream层次关系图，点击[graph]视图:

3. 选择你想要查看的streams depot。P4V 将显示类似于如下的视图，视图中体现各个stream

的父子关系和stream的状态。例如：

如欲了解更多关于P4V中的streams功能，可以参照在线帮助。其他信息，可以查阅《Perforce

入门》，《P4用户指南》和《Perforce命令参考》。
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重要且有用的功能

在P4V 提供的众多功能中，下列功能特别有用：

• 工具提示：想要了解界面上各个控件的更多信息，把光标移到该控件上，P4V 即弹出对话

框说明该控件的更多信息。

• 拖放: P4V包含许多共通操作的拖放快捷方式。

• 文件视图：P4V允许你利用缩略图预览图形文件。

• 分离窗口：为了在单独窗口中显示式样，你可以分离窗口。

以下章节提供更详细的信息。

工具提示

P4V 为画面上的众多控件提供工具提示。例如，为显示一个文件的状态，把光标移到左侧面

板中的该文件上。P4V显示如下的工具提示。

另一个例子：为显示  changelist  注释，点击工具栏    并把光标移到右侧面板的这个

changelist上。所有P4V按钮都会有类似的工具提示信息。

拖放

P4V 为共通任务提供拖放快捷方式。拖放能简化大批量文件的操作。例如，要把一个文件夹

中的所有文件签出，只要把该文件夹拖放到一个changelist即可。要比较两个文件，只要把其中

一个拖放到另一个。如果想了解更多关于拖放快捷方式的话，你可以参照P4V在线帮助。

文件视图

如果你用Perforce管理图形文件，  P4V的缩略图视图能使你预览这些文件。要显示缩略图，

点击右侧面板的文件子标签页，然后从标题栏中选择所需的缩略图尺寸。

P4V显示如下的缩略图。
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分离窗口

要保持一个子页为打开状态，你可以把它分离出去。例如，右击一个文件并选择文件历史，

然后选择[Window] > [Undock Tab]. P4V 把它打开为如下图所示的独立窗口。

要把它恢复到主窗口，选择[Window] > [Dock Window].

设置[Preferences]

要 配 置 P4V, 编 辑 它 的 首 选 项 (Mac:  [P4V]  >  [Preferences],  Windows:  [Edit]

>[Preferences]). 在[File Editor]子页，你可以设置文件类型与应用程序联系起来，以覆盖系

统设置。在[Diff]和 [Merge]子页，你可以根据自己的喜好，绑定除P4V系统默认工具以外的外
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部应用程序。
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重要且有用的功能

从命令行启动P4V 组件

如果你是 Perforce 命令行客户端用户，偶尔利用 P4V 的某些功能，例如查看版本演变图或

Stream图，你可以利用P4VC（一个包含在P4V中的命令行工具）来从命令行启动具体的P4V组件，

而不必打开整个P4V实例。如果想了解更多信息的话，你可以在命令行输入p4vc   help命令。
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从 P4Win迁移

从P4Win迁移

如果你正在从P4Win迁移到P4V，以下的等价操作列表有助于你的迁移。

P4Win 菜单项

Add to Source

Control…

菜单位置

File

P4V 菜单项 菜单位置

Actions

注意

Mark for Add 仅在工作区中的

文件上操作。

图形化标注工具Annotate File…

Diff 2 Files,

File

File

Time-lapse View

Diff…

Tools

Tools

Folders or

Revisions

Diff Client File vs.

Depot File

File Diff… Tools 或者右击文件选

择 Diff Againt

Have Revision

Explore File

File

Show in>Explorer

Integrate

File

Integrate using

Filespec or

Branchspec

Open for Delete

Open for Edit

Properties

Actions

File

File

File

Mark for Delete

Check Out

Actions

Actions

ViewFiles in Folder 文件属性将在文

件列表底部的详

情面板中显示

Remove from

Client

File Remove From

Workspace

Rename/Move…

History

Actions

Rename File

File

Actions

ViewRevision History… 也可以右击文件

选择 File History

也可以右击文件

选择 Open

View File… File Open File

Check File>More Reconcile Offline

Work…

Actions 仅对工作区中的

文件夹有效Consistency

Auto Resolve…

Interactively…

[Resolve]

File>Resolve

File>Resolve

Resolve…

Resolve…

Actions

Actions

Schedule File for

Resolve

File>Resolve Get Latest Revision Actions
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从 P4Win迁移

P4Win 菜单项

Sync to Head

Revision

菜单位置 P4V 菜单项 菜单位置

Actions

注意

File>Sync Get Last Revision

Sync… File>Sync

Edit

Get Revision

File File…

Actions

EditFind File Matching

Pattern…

Find File Under

Selected Folder…

Bookmarks

Client View of

Depot

Edit Find File… Edit

View

View

Bookmarks

Depot Tree

Tools

View 限制在客户端视

图：View>Filter

Depot>Tree

Restricted to

Workspace View

ClientSpecs

Describe

View Workspaces

Go To…

View

Edit(任何描述菜

单)

直接导航至期望

的描述

Entire Depot View Depot Tree View 显示整个 depot：

View>Filter

Depot>Entire

Depot Tree

Local View of

Client Tree

Show Deleted

Depot Files

Show Deleted

Depot Files

Favorite

View Workspace Tree

Workspace Tree

View

ViewView

View Show Deleted Depot

Files

View>Filter

Depot

Settings Favorite Connection

Connections

Log OffLogout Settings

Settings

Settings

Connection

EditOptions… Preferences…

Open RecentPort Client User

History

Connection

Set Password for

(current user)…

User Change Password… Connection
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P4Win 菜单项

View Users

菜单位置

User

P4V 菜单项 菜单位置

Tools

注意

Administration 超级用户可以通

过 P4V 管理用户

和用户组
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后继工作

该指南帮助你开始使用P4V来操作文件并指出重要的基本功能，但P4V能使你做更多的工作，

如：创建作业、分支文件组以及处理在团体开发设置中出现的文件冲突。

Perforce管理员通过选择[Tools] > [Administration]能执行管理操作。利用管理工具，超

级用户能管理用户和组以及他们对depot中文件和文件夹级别的访问权限设置。但某些管理功能

仍必须在 Perforce 命令行客户端（p4）上执行。欲了解更多详情，可以参照《Perforce 命令参

考》和《Perforce系统管理员指南》。

如果希望精通P4V，你可以：

• 查看《P4V在线帮助手册》,以及从Perforce网站阅读Perforce用户文档。

• 利用工具提示。

• 留意左侧面板中的文件图标和图示。图示和图标显示有关文件类型和状态的大量信息。

• 学习阅读日志面板。

• 学习利用拖放快捷方式来简化大批量文件的操作。

• 利用P4V视图和筛选功能有选择地显示信息。

如果想了解整体状况的话，你可以查阅《P4V 在线帮助手册》、《Perforce入门》以及《Perforce

系统管理员指南》。你可以从Perforce网站获得本指南的英文版。该指南中描述了Perforce服

务器提供的全部功能。Perforce 技术支持也可随时为你提供服务，此外还有 perforce-user  邮件列

表和Perforce论坛。详情请访问我们的网站。

Perforce中国合作伙伴，上海龙智数码科技股份有限公司(http://www.shdsd.com)提供本地化的

Perforce咨询、支持、培训等服务。可以通过以下方式取得联系：

电话：400-7755-506

邮箱：perforce@shdsd.com

或者关注  新浪微博、博客：

@Perforce中国授权合作伙伴

随时获取Perforce相关的最新咨询。
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